ISSUE:
Annoying Outlook Prompt
When using the Outlook Integration, you receive a message similar to the following:
A program is trying to access data from Outlook that may include address book information. Do you want to allow this?
A program is trying to access data from Outlook that may include address book information. Do you want to allow this?
CAUSE:
Your Computer is Insecure
If you are getting the error above, your computer is insecure. Please follow the Resolution steps and only perform the Workaround steps as a last resort.
This is an Outlook security setting that occurs on machines that either:
1. Do not have antivirus enabled
2. Are not using Windows Defender
3. Or are unable to determine the status of antivirus software
1. Do not have antivirus enabled
2. Are not using Windows Defender
3. Or are unable to determine the status of antivirus software
RESOLUTION:
Activate Antivirus
This is the ideal way to resolve this issue.
The best resolution to this problem is to upgrade to Windows 10 using Windows Defender as your antivirus. As an alternative, applying all Microsoft Updates to your Windows 8 or Windows 10 machine and applying all updates to your antivirus program will resolve the issue.
WORKAROUND:
Disable the Warning
Only do this if you are not able to perform the Resolution steps.
This security alert can be disabled in Outlook. To do this, you will need to do the following:
1. Completely exit Outlook.
2. Launch Outlook as Administrator (Right-Click on its shortcut and choose "Run as Administrator")
3. In Outlook, go to File > Options > Trust Center > Trust Center Settings > Programmatic Access.
4. Select "Never warn me about suspicious activity" and click "OK" until you are back to the main Outlook screen.
5. Exit Outlook
6. Re-open Outlook normally.
Once the steps above are completed, you will no longer receive the specified error.
1. Completely exit Outlook.
2. Launch Outlook as Administrator (Right-Click on its shortcut and choose "Run as Administrator")
3. In Outlook, go to File > Options > Trust Center > Trust Center Settings > Programmatic Access.
4. Select "Never warn me about suspicious activity" and click "OK" until you are back to the main Outlook screen.
5. Exit Outlook
6. Re-open Outlook normally.
Once the steps above are completed, you will no longer receive the specified error.
Was this article helpful?
That’s Great!
Thank you for your feedback
Sorry! We couldn't be helpful
Thank you for your feedback
Feedback sent
We appreciate your effort and will try to fix the article